Two new Swing DnD methods need revision:
It is unclear what this method will be used for and I believe it could pose a problem when DnD actions are dealt with in a later release. It should be removed.
This method is currently only called to allow the developer to have the component indicate the drop location when canImport() returns false. It makes sense however for the method to also allow them to NOT show the drop location when canImport() is true. It should be renamed to shouldIndicate() and be called for every import.
The new signature should be:
boolean shouldIndicate(TransferInfo info, canImport boolean)
The canImport boolean will represent the return value from the previous call to canImport() and by default this method should simply return that boolean (to have the drop location indicated only if canImport() is true).